*

WordPressプラグインエラー(cdnvote)

公開日: : PHPで実際開発して, Wordpress

これは僕のメモです。

 

WordPress4.2に、3.2以降更新されていないプラグイン「cdnvote」をインストールすると、
エラーになります。

 

cdnvote:投票システムを追加するプラグイン。
サンプル:全国ミスコンテスト投票所2015
http://yuumeijin.org/missc15/
機能:投票用のテーブルを1つ作る
それに伴い、投稿を投票が多い順に並べる。

WordPressのバージョンの関係とは別に、PHPのバージョンの関係かもしれません。
PHP5.0xだと動くと思います。

 

エラー:

「Warning: Missing argument 2 for wpdb::prepare(), called in」

 

原因:

WordPress3.5より prepare関数の第2引数が必須になりました。

 

 

対処:

WordPress3.5にしたらprepareでエラーが出た場合

wp-db.php中に
function prepare( $query = null ) { // ( $query, *$args )
->
function prepare( $query, $args ) {
に変える
第2引数$argsが必須

細かい構文は上記サイトにあります。

 

 

スポンサーリンク

関連記事

Worpressでの自動改行機能の現象と対策

Wordpress3.4.1にプラグイン「exec-php」をインストールし、 以下のコードを書き

記事を読む

複数の引数を渡す方法

これは僕のメモです。   <?PHP //引数,複数の引数を渡

記事を読む

no image

PHPをインストールする時、いつも忘れる事(short_open_tag)

一般的なマニュアルだと、以下の2箇所の修正で ApacheがPHPファイルを認識する。 1.h

記事を読む

phpMyAdminでエラーが出るようになった

インポート → 失敗 delete from Tabel →インポート → 失敗 を繰り返してい

記事を読む

xserverでmysqlへの接続(PHPのバージョンに注意)

これは僕のメモです。 Xserverを借りています。 PHPのバージョンにより、

記事を読む

no image

OpenSSLが有効になっていない」

レンタルサーバでは何も問題ない、localhost(apache2.2,PHP5.3)だと以下のエラ

記事を読む

phpmyadminで編集できない時の対応

これは僕のメモです。 phpmyadminで編集・コピー・削除が表示されない時 ->

記事を読む

プレースホルダ(プリペアド・ステートメント)で2つのテーブルを比較するときの注意

これは、自分のメモです。(自分の勉強用フォルダren/ren112.php) テーブルを2つ読

記事を読む

がそのまま文字列で表示されてしまう

  これは僕のメモです。   OSやウェブサーバーの種類等

記事を読む

阪神タイガース関連新聞記事のTweetとHtmlタグ

  これは、僕のメモです。 1.前提その1: まず、プログラム動かす

記事を読む

Windows10(x64)に、Apache2.4(x64)、MySQL5.7(x64)、MyCDBC(x86)、PHP 7.1.10、OfficeProffesional2007(x86)をインストールする

これは僕自身のメモです。 ノートパソコンに上記のものをインストールす

XserverでのMySQLからMariaDB

これは自分のメモです。 Xserverでは自動的にMySQLからMa

複数の引数を渡す方法

これは僕のメモです。   <?PHP

phpmyadminで編集できない時の対応

これは僕のメモです。 phpmyadminで編集・コピー・削除が

CSSの変更をChromeにすぐ反映させる方法

これは、僕自身のメモです。   『スーパーリロー

→もっと見る

PAGE TOP ↑